Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000949Taste[All Projects] ASN.1 Compiler v4public2021-07-03 13:032021-09-16 12:43
Reportergmamais 
Assigned Togmamais 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Summary0000949:

Precision issue in .net core

Description

In the new version of ASN1SCC we spotted a difference in the range generated in the code for double precision reals.

The type is defined like this:

T-Double ::= REAL (-1.7976931348623157e+308..1.7976931348623157E308)

Because of this difference the new code cannot be compiled - the Ada compiler detects that the value is out of range and raises an error.

TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0003793)
gmamais (developer)
2021-07-03 13:06

fixed in latest commit in GitHub
A new test case added for this issue.

(0003794)
maxime (administrator)
2021-07-07 14:42

Thanks. But I see the CI job failed?

(0003798)
maxime (administrator)
2021-09-16 12:43

Thanks! closing


- Issue History
Date Modified Username Field Change
2021-07-03 13:03 gmamais New Issue
2021-07-03 13:03 gmamais Status

new => assigned

2021-07-03 13:03 gmamais Assigned To

=> gmamais

2021-07-03 13:06 gmamais Note Added: 0003793
2021-07-03 13:06 gmamais Status

assigned => resolved

2021-07-03 13:06 gmamais Resolution

open => fixed

2021-07-07 14:42 maxime Note Added: 0003794
2021-09-16 12:43 maxime Note Added: 0003798
2021-09-16 12:43 maxime Status

resolved => closed



Copyright © 2000 - 2011 MantisBT Group
Powered by Mantis Bugtracker