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IMPORTANT - Always make sure you are using the latest version of the TASTE tools. 
From within the TASTE Virtual machine, you can click on the Update-TASTE icon. 

From a terminal, you can run the Update-TASTE.sh script, and close the terminal when it is done. 

 
STEP-BY-STEP TUTORIAL 

 
Step Actions Comments 

Create a new project Create a new working directory and start the TASTE editor. 
Most of the work can be done from within this single tool.  

 
Run this command from a terminal to create your system: 

 
$ taste-create-interface-view 

 
 
 
 

 

Later on, you can re-open/edit your project by typing: 
 
$ taste-edit-interface-view 

 
This editor will open: 

 



Step Actions Comments 
Add functions and 

containers 
In the editor, right-click to open the contextual menu 

 
Add functions and specify for each of them: 
 

- Their name 
- Their interface (provided and required) 
- Their implementation language 
- Their description 
- Their context parameters (if any) 

 
With the mouse, you can click on a required interface and 
connect it to the provided interface of another function. 

Context parameters allow to specify: 
- Typed static data (usable in the functional code) 
- Timers 
- Compilation flags 
- Context-dependent data that can be processed during 

the build, such as reference to some external 
initialization parameters, etc. 

 
Provided interface can carry parameters. You can use the 
default data types (UInt32, Boolean, etc) or create your own 
types (see step below) 

Specify data types Select the menu item File->Dataview->Edit Data View to 
open the ASN.1 text editor.  

 
You can modify existing types or create your own. 

 
Save and close when you are done ; if no syntax error is 

found then the data types are reloaded in the model editor. 

 



Step Actions Comments 
Edit the functional 

code or models 
On the main diagram, right-click on a function to open the 

contextual menu. 
 

Depending on the implementation language you chose for 
the function, select the relevant editor (“Edit Ada 

code”,”Open SDL editor”, etc.) 
 

If you want to work with your own external tools (e.g. 
Simulink or RTDS) you have to generate the code skeletons 

first using the menu option Tools->Generate code skeletons. 
 

For C and Ada a text editor is opened (Kate). 
 

For SDL the OpenGEODE tool allows to create graphical 
state machines and generate code.  

 
For all supported languages a model (or code) skeleton is 

automatically generated, ensuring consistency of the 
interfaces in the complete system. 

Create deployment 
view 

On the main diagram, right-click and select the option to 
Edit Deployment View 

 
The deployment view allows to map the software functions 

on hardware components, and add buses and drivers in case 
of a distributed system. 

 

On the left side of the editor, you can select processor 
boards, busses, and drivers. Drag and drop what you need to 

the diagram. 
 

On the partition, right click and select the functions you 
want to bind to the chosen processor. 

 
The name of a partition is the name of the target application 

that will be generated.  
 

 



Step Actions Comments 
(Optional) 

Tune the real-time 
attributes of your 

system 

From the deployment view editor, you may select the  
Tools->Edit Concurrency view option in the menu. 

 
This editor allows you to view the threads that will be created 
for your system and edit some properties for fine tuning of 
the application: 
 

- Thread priority 
- Stack size per thread 
- Phase (or offset) 

 
You can also run the Cheddar and the Marzhin analysis tools 
that are built-in, to check scheduling analysis of your system. 
 
For these functions to work you must have specified the 
worst case execution time of each provided interface of your 
system. 
 
Close the Concurrency View and Deployment View editors to 
go back to the main tool editor (Interface View editor). 

 
Build the system From the Interface View editor, you can build your system 

from the Tools->Build the system option. Two runtime 
systems are proposed (C or Ada). 

 
Another window will show you the build progress and report 

errors if any. 

Between two builds you may want to use the option 
 Tools->Cleanup output (binary) directory.  It can happen 

that files from a previous build pollute the next build in some 
situation. If you do not cleanup, a subsequent build will be 

done much faster as only the modified data will be 
recompiled. 



Step Actions Comments 
Run the system and 

interact with it 
When the build is done, you can quit the editor and explore 
the directory where the generated application was created. 

 
$ cd binary.c/binaries 
 
If your system contains GUI components, a binary per GUI is 
placed in that same directory. 
 
You can either run your applications directly (on the chosen 
platform) or activate tracing function: 
 
$ taste-run-and-trace ./my_demo 
 
At the end of the execution (stop it with Ctrl-C) a file 
trace.msc will appear. Open it with the MSC editor: 
 
$ msce.py –o trace.msc 
 

 

The tracing tool records all the internal communication 
between your functions, as well as the timers. 
 

 
 
 

FOR MORE INFORMATION – Check the TASTE wiki here: http://taste.tuxfamily.org 
You will learn more about the SDL editor, the use of timers, the use of Python scripts to test your system, and the use of SQL 

databases in combination with your ASN.1 data model. 
 

http://taste.tuxfamily.org/


TASTE V2 Quick Reference Card 
Integration of a Simulink block as part of a TASTE system 

 
Action Illustration Notes 

Create an interface 
view to capture the 
Simulink function 

 
 
 

 

The Simulink block must have only 
ONE provided interface and NO 

required interface.  
 

The provided interface can contain 
any number of INPUT and OUTPUT 

parameters using the ASN.1 types. 
 

The provided interface must be set 
either as PROTECTED or 

UNPROTECTED. 

Generate the 
function skeleton 

Right-click on the diagram and select the option Generate code 
skeletons. 

 
 

A new directory is create with the 
following files: 
 
my_simulink_function/ 
|-- Simulink_DataView_asn.m 
|-- my_simulink_function_script.m 
|-- setInputsBusCreator.m 
`-- setOutputsBusSelector.m 

Start Matlab and run Inside Matlab right-click on This script calls the other ones.   



Action Illustration Notes 
the script generated 
by TASTE 

“my_simulink_function_script.m” and choose Run File: 

 

The Matlab workspace will be 
updated with new data types and 
busses, that result from the ASN.1 to 
Matlab type conversion. 
 
After a short while a new file will 
appear next to the Matlab scripts: 
Add_Two_Params.mdl (this is the 
name of the interface we gave as an 
example). 

Open the mdl-
generated file 

Double-click on Add_Two_Params.mdl to open the Simulink 
editor: 

 

 

What you see is the skeleton of the 
function you specified in the TASTE 
interface view. 



Action Illustration Notes 
Fill the function by 
connecting the input 
and the output of the 
block. You can use 
blocks from the 
Simulink library. 

 

 

Generate the code 
from the Simulink 
model 

Usually this is straightforward. Go to the menu Tools->Real-Time 
Workshop->Options then tick the Generate code only option and 

click on Generate code.  

 
 

This might take a while, you can 
follow the progress on the main 
Matlab console. 
 
When it is done, the following file 
appears in your working directory: 
Add_Two_Params.zip 
 

 
 
 

Copy and unpack the 
generated code back 
to TASTE working 
folder 

If Matlab was not installed in your TASTE Virtual machine and you 
had to copy the .m scripts to a different machine, copy back the 

generated zipfile to your TASTE working folder and unzip it. 
 

cd my_simulink_function 
unzip Add_Two_Params.zip 

A lot of files will appear. The reason is 
that Simulink copied in the zipfile 
ALL files required to make an 
independent compilation of the 
project (which is what TASTE needs).  



Action Illustration Notes 
Call the Simulink 
block from another 
TASTE function 

As an example you can add a periodic interface to a function you 
may call “My_C_Function” (implemented in C) 

 
Calling the Simulink block is like invoking any other required 

interface. The call is synchronous, which means you get the result 
“immediately”. 

 

 

 

Build the system and 
run it 

Create a deployment view – do not forget to put both functions in 
the SAME partition (synchronous functions cannot reside in a  

physically different computer)  

 
 

Then run ./build-script.sh 
 

 

 



TASTE V2 Quick Reference Card 
Using Simulink Tunable Parameters 
and TASTE PeekPoke functionality 

 
Checkout demo in ~/tool-src/testSuites/Regression_AADLv2/Demo_Tunable_Params_PeekPoke 

This tutorial explains how to import the special PeekPoke component to a TASTE system. The PeekPoke component allows to 
monitor and change parameters of any function of the system without having to add dedicated interfaces. It can be used to 

tunealgorithms or to check the evolution of any global variable of the system at runtime (it can plot and record data). 
  

Action Illustration Notes 
Create a system that contains a 
Simulink block, and click on the 

“Functional States” tab in the Simulink 
function block 

 
Enter variable names, choose 
“Simulink_Tunable_Parameter” 
type, and set a value. 
 
Click on OK when you are done. 

 

Values have to be 
numerical (integer or 

real). They can be multi-
dimensional as shown in 

the screenshot. 

Right click and select “Import”. 
 

Choose file 
“export_PeekPoke.aadl” in 

directory /home/assert/tool-
inst/share/peekpoke/componen

t and click on Open 
 

You can save and close the interface 
view editor. 

 

A small container with 
two functions will 

appear in the lower right 
hand corner of the 

interface view.  
 

Generate function skeletons taste-generate-skeletons Result: 



Action Illustration Notes 

 
Open Simulink and run the main 
script: mysimulink_script.m 

 
 

 

The two tunable 
parameters appear in the 

Matlab workspace. 

Fill up the Simulink skeleton and make 
use of the tunable parameters  

 
(otherwise the code generator will skip 

them) 

 

Use tunable parameters 
wherever you need at 

runtime to monitor and 
patch data (e.g. to tune 

an algorithm). 

Generate the code from the Simulink 
model and unzip the resulting file back 
in the folder where TASTE generated 

the .m scripts. 

  

Create a deployment view and map 
your functions on hardware.  

 

The TASTE_Probe 
component must be 

placed on the same node 
as the function 
containing the 

parameters you want to 
monitor, while the 

TASTE_Probe_Console 
component must reside 

on a native platform 
(Linux). 

Build the system From the interface view editor, run the menu option: 
Tools->Build the system (in C or in Ada) 

 

Run the main system binary $ cd binary.c/binaries 
$ ./demo 

 

 

Open a new terminal and run the 
PeekPoke GUI 

$ cd PeekPoke 
$ ./peekpoke.py ../demo 

A GUI shall appear 



Action Illustration Notes 
In the GUI, start typing the variable 

name you want to monitor. The 
complete name shall appear. 

 
Select the variable type (real double) 

 
Select the number of elements (1) 

 
Select the sampling time (1) 

 
Click on:  

Add to list of monitored 
variables 

 

The tunable parameter 
value will appear 

immediately in the 
bottom table. 

If the Simulink model 
execution modifies the 

value, it will be reflected 
at the next sample time. 

 
You can monitor all the 
binary’s global variables 

(not only Simulink 
tunable parameters). 

Just start typing a 
variable name and add it 

to the list. 

Select a value, and click on one of the 
options (Plot, Meter, Un-plot, Un-
meter, Set selected to this 

value) 

 

Use this feature to patch 
data at runtime (possibly 

on target) and see how 
your system reacts 
(inject faults, tune 

algorithms…). 

Record monitored values: click on Choose 
filename and select a (.csv) text file. 

Tick/untick the “Append monitored 
values to file” checkbox. 

 
 

The resulting csv file can 
be open in a spreadsheet 

for post-processing. 



Action Illustration Notes 

 
You can save the graphical layout. When 

you reload it, all plots/meters will appear at 
the same place and monitored variable 

values will automatically be updated again. 
 

File -> Save As 
 

Then File -> Open 

  

 
 
 
 
 



TASTE V2 Quick Reference Card 
Function semantics (from the TASTE Training slides) 

 



TASTE V2 Quick Reference Card 
ASN.1 (1) 

 
ASN.1 is used to describe the data type of function parameters 



TASTE V2 Quick Reference Card 
ASN.1 (2) 

 
 

 
 
 
 



TASTE V2 Quick Reference Card 
ACN 

 
ACN allows to specify legacy encodings – It can be used to describe the format of PUS packets, leaving only the “interesting part” 

(payload data) in the ASN.1 model 
Check the documentation in /home/assert/tool-src/doc/acn 

 

MySeq ::= SEQUENCE { 

 alpha  INTEGER, 

 gamma REAL OPTIONAL 

} 

MySeq[] { 

 alpha [], 

 beta  BOOLEAN  [], 

 gamma [present-when beta, encoding IEEE754-1985-64] 

} 



ASTE V2 Quick Reference Card 
SDL - OpenGEODE 

 
SDL is language that can be used to model state machines, and generate code. TASTE support a commercial tool (RTDS), and 

hasits own built-in editor (opengeode) for simpler functions. 
Check the training material for description of all symbol. Additional information on www.opengeode.net 

 

  


